Dashboard Browser Support

 

Having trouble with your web browser? Petfinder will be supporting the following web browser versions or higher. Members will need to use one of these compatible web browsers in order to continue reliably using and accessing Petfinder:

Chrome 38 or higher
Firefox 38 or higher
Safari 8 or higher
Opera 35 or higher
Internet Explorer 11 or higher
Edge 13 or higher
Safari for iOS

To determine your current web browser and web browser version number, just go to http://www.useragentstring.com/ and look at the line just under “Copy/paste any user agent string”.

A few examples of what you may see include:

Chrome 55.0.2883.95
Firefox 50.0
Safari 10.0

Or, you can go to the Menu/File section of your web browser and choose “About”.

If you need to update your preferred web browser, you can easily do this by following one of the links below:

To update Chrome:

https://www.google.com/intl/en/chrome/browser/desktop/

To update Firefox:

https://www.mozilla.org/en-US/firefox/new/

To update Opera:

http://www.opera.com/

Internet Explorer and Edge are automatically updated depending on your PC.  Typically, most PCs made after 2013 will have Internet Explorer 11 / Edge 13 or higher.

Safari is automatically updated depending on your Mac.  Typically, most Macs made after 2012 will have Safari 8 or higher.

Safari for iOS is automatically updated depending on your iPhone/iPad/etc.

If you have additional questions or need further assistance, please contact the Petfinder Technical Team

Looking for something different? Return to our Help Center.